Softwarepatch is Uniblue's online bible for all software-related matters.
Windows Monthly Security Updates and Patches - June 2011
Never look for drivers again. Download the latest version of any driver now

Applies to:

Microsoft Windows

Category:

Security Updates

Requirements:

Windows

Rating:


4
/5 from 20 reviews.

Description:

June 2011

Vulnerability in OLE Automation Could Allow Remote Code Execution (2476490)
Requirements: Windows XP SP3
[Click here to Download]


Vulnerability in .NET Framework and Microsoft Silverlight Could Allow Remote Code Execution (2514842)
Requirements: Windows XP SP3 .NET Framework 4.0
[Click here to Download]


Vulnerability in Threat Management Gateway Firewall Client Could Allow Remote Code Execution (2520426)
Requirements: Microsoft Forefront Threat Management Gateway 2010 Client
[Click here to Download]


Vulnerability in Windows Kernel-Mode Drivers Could Allow Remote Code Execution (2525694)
Requirements: Windows XP Professional 64-bit
[Click here to Download]




PC Mechanic - Fix your PC's Windows registry errors.

Vulnerabilities in Distributed File System Could Allow Remote Code Execution (2535512)
Requirements: Windows XP SP3
[Click here to Download]


Vulnerability in SMB Client Could Allow Remote Code Execution (2536276)
Requirements: Windows XP SP3
[Click here to Download]


Vulnerability in .NET Framework Could Allow Remote Code Execution (2538814)
Requirements: Windows XP SP3 .NET Framework 4.0
[Click here to Download]


Cumulative Security Update for Internet Explorer (2530548)
Requirements: Windows XP SP3 Internet Explorer 8
[Click here to Download]


Vulnerability in Vector Markup Language Could Allow Remote Code Execution (2544521)
Requirements: Windows XP SP3 with Internet Explorer 8
[Click here to Download]


Vulnerability in MHTML Could Allow Information Disclosure (2544893)
Requirements: Windows XP SP3
[Click here to Download]


Vulnerabilities in Microsoft Excel Could Allow Remote Code Execution (2537146)
Requirements: Microsoft Office 2003 SP3
[Click here to Download]


Vulnerability in Ancillary Function Driver Could Allow Elevation of Privilege (2503665)
Requirements: Windows Vista SP1 and SP2
[Click here to Download]


Vulnerability in SMB Server Could Allow Denial of Service (2536275)
Requirements: Windows Vista SP1 and SP2
[Click here to Download]


Vulnerability in outdated drivers. Make sure you are running tha lastest versions.
Requirements: Windows XP, Vista and 7
Manufacrurers recommend installing the latest drivers to mitigate the presence of system bugs and security holes that can lead to system crashes and security breaches. Leave the hard work to us by downloading our very own, newly released DriverScanner. At the click of a button, DriverScanner scans and updates your drivers to the latest versions released by manufacturers, making sure your system is up-to-date and secure.
[Click here to Download]